Jump to content
  • 0

Sweet Gelato Auto®️ Leaves


soporte
 Share

Question

5 answers to this question

Recommended Posts

  • 0

Perhaps the problem may be due to poor aeration in the plant. Or also, perhaps a phosphorus or potassium deficiency.

 

But seeing the state of health of the plant, you shouldn't worry. But... You can reduce the use of fertilizer with nitrogen, the color so green and those saw blades may indicate that it has a bit of overfertilization. Try to give them a break. :))

 

Also, if you are using a pot less than 7 liters, you can do a transplant to another bigger pot.

 

In short, have good ventilation, and reduce the fertilizer with nitrogen. ;);)

 

 

Sweet smokes,

-Apolo

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

Sweet Seeds®

Sobre nosotros
Aviso legal

Síguenos:

 

×
×
  • Create New...

Important Information

You must review the Terms of Use, Privacy Policy and 📚 Guidelines We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.